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Introduction

clCertify checks and certifies that .csv files satisfy all the requirements for data transfer files
as according to version 2.1 of CoallLog - Borehole Data Standard for the Australian Coal
Industry (https://ausimm.com/coal-log/). This standard includes data entry sheets and
standard code lookup tables for header, drilling, casing, cementing, lithology, water flow and
geotechnical data, a format for the transferal of this data, a borehole logging training manual
and standard plotting patterns for all its lithotypes and lithology qualifiers. It was first
released in February 2012 and the current version (v2.1) was released in August 2015.

clCertify can also optionally check and certify that data transfer files also satisfy NSW
Government requirements for submission of coal exploration data.

Amongst the changes to CoallLog over its various releases, there have been a small number
of changes that meant that data that previously satisfied the standard no longer do. For
example, earlier versions of the standard had only one Hole Status field in the Header and
this had the name Hole_Status whereas later versions had two such fields and their names
are Hole_Status_1 and Hole_Status_2. As well as checking the data clCertify provides a
facility to convert CoallLog data transfer files that satisfied earlier versions of CoallLog, to the
current standard.
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Selecting Files to be Checked

When clCertify is opened the user is prompted to select the files to be checked and/or
reformatted. Multiple files can be selected using standard Windows file selection
procedures, using the Shift and Ctrl keys, but all the selected files must be contained in a

single folder:
@ Select File to Open bt
Look in: I Test Data j " cf B

* MNarme Date modified Type Size 2

) CDS_casing.csv 03-May-18 318 PM Microsoft Excel C... 1KB
Quick access - .

CoalLog_Headers.cw 19-Jun-18 2:56 PM Microsoft Excel C... TKB
[Vl CoalLog_Litho.csv 28-May-1812:33P  Microsoft Excel C... 12 KB
Desktop Test_casing.csv 04-Apr-1811:41 AM  Microsoft Excel C... TKB
. Test_DriIIing.csv 22-Jun-12 412 PM Microsoft Excel C... 2 KB
™ Test_headers.csv 17-Jul-18 6:21 PM Microsoft Excel C... KB
Libraries Test_litho.cs'.r 19-Jun-18 5:13 PM Microsoft Excel C... 109 KB
! Test_old_casing.csv 20-Jun-18 2:32 PM Microsoft Excel C... 1KB
Test'l_headers.cw 04-Jul-18 4:43 PM Microsoft Excel C... 5KB
Lol {1 Test2_headers.csv 11-Jul-18 356 PM  Microsoft Excel C... 5KB
@ TestZ_Litho.csv 03-Jul-18 5:02 PM Microsoft Excel C... 6 KB
Network TestS_Litho.csv 26-Jun-18 6:29 PM Microsoft Excel C... 6 KB
Test4_Litho.csv 03-Jul-18 53:43 PM Microsoft Excel C... B KB

AL Tects 1ithn e Nd-10l-12 1190 KA Mirrasnft Fecel © 1kR ¥
File name: ICoaILog_L'rtho.csv j Open

Files of type: Icsv Files (" cav) d 4|Cance-l
|

Of the selected files, only those whose names match the CoalLog convention for the naming
of data transfer files, will be processed. That is they must have an extension of .csv and the
type of data that is contained in the file must be indicated by the first four characters
following the last space or underscore in the file name, see Table 1 for valid data type
indicators. Naming conventions are not case sensitive.

For example;

Avc030§ Casthg.csv
AVCD3Ding.csv

The user can select a new set of files at any time by selecting File > Open from the menu at
the top of the window:

g clCertify - [ClCertify]
"= File Tools Settings Help
Elc Open
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Coallog Data Type

First four letter following
last underscore or space
in filename (not case

sensitive)

Headers Head
Geologists Geol
Casing Casi
Cementing Ceme
Drilling Dril
Lithology Lith
Sample Dispatch Samp
Water Observations Wate
RMU & Defects Defe
Point Loads Poin

Table 1: CoalLog data transfer file Data Type indicators for file naming convention.
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Checking Files

To check the files that have been selected select Tools > Certify from the menu at the top of
the window:

mig clCertify - [C\UsrclCertifyh Test Data]

"= File Tools Settings  Help
Elcausey Certify F

| Reformat to Coallog Vers. 2.1

clCertify will then display on the screen and/or write to text files any errors that are
encountered while checking the file. The user can choose whether errors are displayed on
the screen and/or written to text files, by opening the Options window from the Settings
drop down menu. Text files listing errors will be placed in the same folder as the file being
examined and will have the same filename as the data file except that they will end with the
words Certification Report.txt instead of the .csv.

Reformatting Files to the Current Version of CoallLog

Some errors encountered will also display the message that a particular feature of the file is
pre-CoalLog Vers. 2.1 and that the file can be reformatted by clCertify:

Error *

# File: AVOCALOG_Headers.csv

LE Row Ma: 1

Column name "Hale_Status” is a pre-Coallog Vers. 2.1 Headers
column name !

The file can be reformated to Coallog Vers. 2.1 by selecting

Tools > Reformat to Coallog Vers, 2.1 from the program's
menu.

OK I Cancel

To reformat all the selected files Tools > Reformat to CoalLog Vers 2.1 from the menu at the
top of the window:

mig clCertify - [C\LogData\AVOCALOG\Exports]
"= File | Tools  Settings Help
ElcaLogl Certify

| Reformat to Coallog Vers. 2.1

On reformatting, the original file is renamed with a prefix of Backup of and the new file will
have the same name as the file that was reformatted.
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Program Options

To open the program options window, select Settings > Options from the menu at the top of
the screen:

mug clCertify - [ClCertify]
"= File Tools  Settings Help
[l cicertity Options

The program options window will then appear:

mg clCertify Options x

Check D ata alzo meets N5W Govemment Requirements

Allow Histarical D ata Codes [shown in Grey in Code Dictionary)
Eror Meszages
] Display Ermors on the Screen

List Ermors to a Test File

List Errors to a Cav File

Include CoalLog E=planations of Emors

There are six options that can be set:

1. Check Data also meets NSW Government Requirements

To enable flexible use of the CoalLog data transfer there are very few mandatory fields in
the CoallLog data transfer format. For example, for Header data the only compulsory field
is Borehole Name whereas Header data submitted to the NSW Government must also
include: Lease Number, Site |d, Borehole Type, Borehole Purpose, Geodetic Datum UTM
Zone, Easting, Northing, Elevation, Date Started, Date Completed, Total Depth,
Geophysical Logs recorded, Date Rehabilitated and Borehole Status.

If “Check Data also meets NSW Government Requirements” is ticked, additional checks
for NSW Government compulsory fields will also be performed and if any errors are found
it will display on the screen messages such as:

Error *

File: Test1_headers.csv
! Row Mao: 2

Mo Hole Purpose has been provided !

MNSW Government requirements specify that Headers data
must contain at least one Hole Purpose,

[ ok ]| cancel
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And/or list in the certification report messages such as:

2 No Heole Purpose has been provided
NSW DPE requires that Headers data must contain at least one Hole Purpose.

2 WARNING: No geophysical logs have been specified
NSk DPE requires that Headers data should specify any downhole geophysical logs that have been recorded.

3 "Rehab_Date" is blank
N5W DPE requires that Headers data must contain a value in the column named "Rehab_Date"
The NSW Government requires the reporting of geophysical logs in header data and seam
name, ply name and sample number in lithology data. However, if any of these are
missing then a warning is provided rather than an error indicated as it is possible for a
variety of reasons that this data was never collected. If though it was collected it must be
included in order to satisfy NSW Government requirements.

2. Allow Historical Data Codes (shown in Grey in Code Dictionary)

The Coallog standard includes a number of codes for codes that may be used with
historical data but should not be used for current data collection. For example, with
Lithology data the Lithology Qualifier IF meaning Inferior is acceptable for coal in
historical data but not currently collected data as it does not explain why the coal is
inferior. Currently collected data should instead use a Lithology Qualifiers such as HA for
heat affected or SY for stony. Codes that should only be used with historical data are
displayed in the CoallLog dictionary in grey. For example:

anthracite AN
canngl {torbanite, bog) T
dull conchoidal DC
ferior IF
sapropelic Sp
stony 5Y

If “Allow Historical Data Codes” is ticked then use of these historical codes will not be
indicated as an error.

3. Display Errors on the Screen

If “Display Errors on the Screen” is ticked a window such as the following pops up on the
screen each time an error is accounted.

Error *

File: Test1_headers.csv
! Row No: 2

Walue “F" in column named "Hole_S5tatus_1" is not a valid
Coallog code for this column !

“Hole_Status_1" can only contain valid Coallog codes,

[ ok ]| cance |

If there are numerous errors, it is probably easier to turn this option off and turn on List
Errors to a File.
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4. List Errors to a Text File

If “List Errors to a Text File” is ticked each error and its row number in the data will be
listed to a file with the same name as the data file but the .csv in the filename being
replaced by Certification Report.txt. After completing the certification check a summary
of the results such as the following will be displayed on the screen:

Status >

0 3 errors detected for Test5_Litho.csv,

All errors and warnings have been written to file:

ChUsrclCertify\Test Data\Avocalog\TestS_Litho Certification
Report.bxd

5. List Errors to a Csv File

If “List Errors to a Csv File” is ticked each error and its row number in the data will be
listed to a file with the same name as the data file but the .csv in the filename being
replaced by Error Report.csv. After completing the certification check a summary of the
results such as the following will be displayed on the screen:

Status >

0 3 errors detected for Test5_Litho.csv.

All errors and warnings have been written to file:

ChUsnclCertifyTest Data\AvocalogiTestS_Litho Error
Report.csv

6. Include CoalLog Explanations of Errors

If “Include CoalLog Explanations of Errors” is ticked full explanations of why something is
in error are included whereas if it is not ticked much more succinct error messages are
provided. For example, if this option is ticked, the previously shown error messages
describing where data does not meet NSW Government requirements on the screen
would be:

Error *

File: Test1_headers.csv
! Row Mo: 2

Mo Hole Purpose has been provided !

MNSW DPE requires that Headers data must contain at least
one Hole Purpose.

ok || cancel
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and in the certification report would be:

2  No Hole Purpose has been provided
NSW DPE requires that Headers data must contain at least one Hole Purpose.

2  WARNING: No geophysical logs have been specified
NSW DPE requires that Headers data should specify any downhole geophysical logs that have been recorded.

3 "Rehab_Date™ is blank
NSW DPE requires that Headers data must contain a wvalue in the column named "Rehab_Date”

If not ticked, on the screen it would be:

Error X

File: Test1_headers.csv
Row Mo: 2

Mo Hole Purpose has been provided !

and in the certification report:
2  No Hole Purpose has been provided
2 WARNING: No geophysical logs have been specified

3 "Rehab_Date" is blank
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Additional Information

Additional information can be obtained by selecting one of the options from the Help in the
menu at the top of the screen:

mig clCertify - [ClCertify]
tmw File Tools Settings | Help

s ClCertify clCertify User Guide
clCertify Technical Guide

Coallog Columns

Coallog Dictionary

Related Apps & Services
About clCertify

There are five options:

1. clCertify User Guide

This displays the clCertify User Guide that you are currently reading.

2. clCertify Technical Guide

This lists all the checks that clCertify performs to check that data is CoalLog v2.1
compliant and the checks that it meets NSW Government Requirements. It also lists all
the modifications that clCertify makes when Reformatting Data to CoalLog v2.1 from
older versions.

3. CoalLog Columns

This displays the current list of valid column names for use in CoalLog data transfer files.
On selecting List CoalLog Column Names, a window appears showing all the valid CoalLog
data types from which the user can select the data type whose column names are
required:

mtg Coallog Columns List >

Fequired Data Type:
Headers
Geologists
Casing
Cementing
Drilling

Sample Dispatch

Water Observations

RMU & Defects

Point Loads Cancel
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After selecting the required data type a window will appear showing the valid CoallLog
column names and for each whether it is mandatory, a description of it, the maximum
number of characters it can have and for columns with numeric data the maximum
number of digits after the decimal point. For example, the list for Lithology is:

mg Coallog Lithology Celumns

O X

tandatary | Column Mame | Description |Max Length |Max Decimal Places|
LaE Project_MName Project 16
v Borehole Name  |Borehole Name 16
:|7 From_Depth Lithology From Depth 8 3
v To_Depth Lithology To Depth 8 3
v Record_Seq_Flag |Record Sequence Flag 1
:I— Recovered_Thick |Recovered Thickness 8 3
L Seam Seam 16
L | Ply Ply 16
L | Horizon Horizon 16
L Sample_Purpose |Lithology Sample Purpose 2
L | Sample_Mo Lithology Sample Number 16
L | Interval_Status Interval Status 1
|~ Litho_Perc Lithology Percentage 3 0
v Litha_Type Lithology 2
L | Litho_Qual Lithology Qualifier 2 v

The NSW Government have further columns that are mandatory above just those that are
mandatory for the standard CoallLog. If “Check Data also meets NSW Government
Requirements” has been ticked in the options window then the list will also show the
additional NSW Government mandatory fields also as mandatory. For example, this
option was not turned on when the above list above was produced but was for the

following list:

mag Coalleg Litholegy Celumns

O X

Mandatary | Calumn Name | Description |Max Length | Max Decimal Places|
1LAN Project_Mame Project 16
v Borehole_Name  |Borehole Name 16
|~ From_Depth Lithology From Depth 8 3
v To_Depth Lithology To Depth g 3
v Record_Seq_Flag |Record Sequence Flag 1
I~ Recovered_Thick |Recovered Thickness a8 3
:|7 Seam Seam 16
|~ Phy Ply 16
L | Harizon Horizon 16
L | Sample_Purpose |Lithology Sample Purpose 2
I Sample Mo Lithology Sample Number 16
L | Interval_Status Interval Status 1
v Litho_Perc Lithology Percentage 3 0
v Litho_Type Lithology 2
_|7 Litho_Qual Lithology Qualifier 2
_l_ Clmda COlhmdn A e

This list has the fields Seam, Ply, Sample_No and Lithology Qualifier indicated as
mandatory as opposed to the previous list which did not.
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4. CoallLog Dictionary

This displays the CoalLog v2.1 Dictionary:

CoallLog v2.1 - Lithology Dictionary

1
[
=]
ca
s
o6

SHADE clear L marly MR stringers F3 WEATHERING

light L coarser (<10% of unit) XC metamorphosed MM traces ™® residual soil

light to medium A conchaidal [<s micaceous Mi wisps WP | extremely weathered

light to dark c dull i} muddy MD

medium E fault gouge FT mudstone MS | Preposition distinctly weathered

medium to dark B finer (<10% of unit) FF oxidised ox and ET

dark D peaty PE as As slightly weathered

banded N heat affected HA phosphatic PP of OF

mattled M interbanded : pyritic PY on ON | fresh

speckled s irregular IR quartzose oz with Wi

variegated v lustrous ] sandstone 55 ESTIMATED STRENGTH
moderately Mo sandy SA Position Unconsolidated Cohesive

HUE / COLOUR opague oP shaly SH alternating AT wvery soft

blackish / black K resinous RS shelly HY near base of unit BU soft

biuish / blue L sideritic sD near middle of unit My firm

brownish / brown B translucent T siliceous sC near top and base of unit XU stiff

buff F silicified SF near top of unit Lt wvery stiff

creamy / cream c Lithological siltstone ST tends to T hard

greenish / green E acidic AC silty si throughout TO

5. Related Apps & Services

This displays a window describing the other Related Apps and Services provided by the
authors of clCertify:

g Related Apps & Services *

GEDLOGICAL DATA SPECIALISTS
clCertify is produced by GeoCheck Pty Lid.
GeoCheck alzo produces a number of other related apps:

LogCheck for CoalLog data: entry and auditing
English reports, hole, seam and sample summaries
genlogy. geophysics, geotechnical and coal quality araphics
araphical editing of geology and geatechnical data to geophysics

LasManager for auditing, correcting and modifying multiple Las files
GeoCheck alzo offers the service of corverting coal exploration data into Coallog format,

Far further information regarding these apps and services ar assistance with elCertify pleaze contact:
Brett Larkin on +81 [0]427 232 264 or supporti@geocheck.com. au
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6. About clCertify

This displays a window with a synopsis of the program, the CoallLog version that it
complies to, the release number of clCertify and contact for support:

m About ClCertify X

clCertify Coallog

AnApp to check and certify that .cav filez zatisfy all Coallog Vers, 2.1
requirements for data transfer files. It alzo provides a facility ta reformat data
tranzfer files from earlier CoalLog versions to CoalLog Wers. 2.1.

Release Mo 1.025
Produced by: GeoCheck Pty. Ltd.. Australia.

Website: v, geocheck. com, au

Far suppart contact: supporti@geccheck. con.au
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